2Click-Iframe-Privacy mit Problemen bei der Verlinkung

  • Hallo zusammen,


    ich habe mich in dieses Forum verirrt, weil ich nach langem Suchen das 01-Script "2Click-Iframe-Privacy" entdeckt habe, welches ganz hervorragend für meine Zwecke einer DSGVO-konformen Darstellung von iframes geeignet ist. Insofern erst mal ein dickes Dankeschön an Michael Lorer, dass er dieses JavaScript zur Verfügung gestellt hat!


    Leider bin ich in JavaScript nicht firm und deshalb hoffe ich hier einen guten Tipp zu bekommen. Ich möchte 2Click-Iframe-Privacy mit dem CMS Contao zum Einsatz bringen. Die Einbindung war auch kein Problem, aber wenn ich (wie in der offiziellen Demo zu sehen) auf "Inhalt anzeigen" klicke, lande ich auf der Startseite anstatt auf der Seite zu bleiben und beispielsweise die GoogleMaps-Karte eingeblendet zu bekommen. Ich habe es nun auf 2 verschiedenen Contao-Installationen probiert, immer mit dem gleichen Ergebnis. Aktuelles Beispiel: https://gutshof-wickensen.de/kontakt.html

    Der Link von "Inhalt anzeigen" verknüpft auf https://gutshof-wickensen.de/#foo anstatt auf https://gutshof-wickensen.de/kontakt.html#foo


    Wenn ich ins Script gehe und dort <a href="#foo" durch <a href="/kontakt.html#foo" ersetze, dann funktioniert es auch. Aber das kann ja nicht die Lösung sein, gerade wenn ich z.B. das Script noch für Youtube-Filme einsetzen möchte, dann passt der veränderte Link nicht mehr... Vielleicht hat da jemand einen Tipp? Es würde mich sehr freuen!


    Danke und beste Grüße

    Leo

  • Hallo,


    erstmal vielen Dank für das Lob. Es freut mich, wenn das Script auf Resonanz stößt.


    Ich habe mir gerade mal die Integration auf Ihrer Seite angeschaut und diese schaut gut aus.

    Das beschriebene Verhalten wird durch folgenden HTML-Code verursacht ( Quelle )


    Code
    1. <base href="https://gutshof-wickensen.de/">


    Dieser bewirkt, dass alle relativen Links (wie z.B. das vom 2-Click-IFrame-Privacy genutzte #foo) relativ zu einem angegebenen Base-Pfad interpretiert werden. Das sorgt dann für die entsprechende Weiterleitung.

    Ich nehme an diese <base-Deklaration wird durch das Contao CMS generiert.


    Ich habe leider noch keine Idee wie ich dem Problem auf möglichst effiziente Weise begegnen kann. Ich versuche mir etwas zu überlegen.


    MfG,
    Michael

  • Hallo Michael,


    danke für die flotte Rückmeldung! Du hast Recht, ich habe das Problem auch in der Contao-Community gepostet und dort fiel der Verdacht auch auf das sog. base-Tag. Und in der Tat, nachdem ich die Zeile heraus genommen habe, funktioniert dein Script! Leider kann ich es so nur in den wenigsten Fällen, da das base-Tag für die meisten Contao-Installationen nötig ist.


    Ich wäre also überaus erfreut, wenn du mal schauen könntest, wie das Problem umgangen werden kann! Dann kann man auch ein wenig mehr Werbung dafür machen, denn solch eine Lösung ist kaum zu finden, obwohl es ja irgendwie genügend Anwendungsfälle geben sollte. Wenn man dazu googelt, findet man fast nur Wordpress-Lösungen...


    Danke nochmal,
    Gruß Leo

  • Hallo Michael,


    besten Dank für dein Engagement :-)

    Momentan komme ich klar.


    Etwas aufwendiger wird es, wenn mal die Kombination Contao-News/Events UND Goolge-Video UND -Maps auftritt. Dann müsste ich ohne die nötigen JavaScript-Kenntnisse das Script 2 x mit unterschiedlichem Namen einbinden und den Pfad entsprechend anpassen. Das wäre zwar nicht galant, geht aber auch. Aber ich freue mich, wenn das dann in Zukunft ohne diese Abänderungen gehen würde!


    Gruß
    Leo

  • Hallo Michael,


    prima, besten Dank für deine Mühe und die Info! Deine Änderung funktionierte auf Anhieb, so konnte ich es nun auch als funktionierende Lösung im Contao-Forum posten :-)


    Danke & Gruß
    Leo