Include-Problem (bug-id198)

Read-Only-Modus

Das 01-Supportforum befindet sich im Read-Only-Modus. Es ist nicht mehr möglich sich zu registrieren, neue Themen zu erstellen oder auf bestehende Themen zu antworten.

Alle Inhalte stehen bis auf absehbare Zeit jedoch weiterhin lesend zur Verfügung.


Bei Fehlern oder Problemen mit PHP-Scripten von 01-Scripts.de erstellen Sie gerne einen Issue-Eintrag auf Github oder nehmen Sie per E-Mail Kontakt auf.

  • 01gbook.php Zeile 50:

    PHP
    1. $filename = $_SERVER['PHP_SELF'];


    Toll das Sie mir wieder helfen wollen.
    Nun habe ich das Problem mit dem $_GET gelöst, ABER...


    Wenn ich nun auf "Neuen Eintrag hinzufügen" im Gästebuch klicke, übergibt er alles fast richtig.
    Aber ich sehe schon den fehler:


    Code
    1. http://inaev.de/index.php?seite=guestebuch?doshow=addentry&gpage=


    Wie schaffe ich es, dass es richtig angezeigt wird:


    Code
    1. http://inaev.de/index.php?seite=guestebuch&doshow=addentry&gpage=


    Also das aus dem zweiten "?" einfach "&" wird.
    Weil so kann er ja das ganz nicht richtig empfangen.
    Mit 2 "?" kann es ja nicht gehen.


    Da liege ich richtig oder?

  • Hallo,


    Problem wurde richtig erkannt und ist mir ebenfalls bereits unter der Bug-ID #198 bekannt.
    Wird mit der nächsten Version offiziell behoben.
    Bis dahin bitte die drei Dateien aus dem Anhang verwenden und die bestehenden Dateien damit überschreiben, dann sollte es klappen, wenn die Zeile 50 erneut bearbeitet wird.


    MfG,
    Michael Lorer


    Edit:
    Dateianhang momentan in Überarbeitung
    Dateianhang wieder hinzugefügt